Click to close the image preview

Showing results for 
Search instead for 
Do you mean 
Most Liked Users
Announcements
CONTEST ANNOUNCEMENT! Enter to win a $50 Amazon Gift Card!
Tell us a personal story of a time when Mozy really helped you out. Did you think all was lost but found Mozy had what you needed? Did it "save your bacon" so-to-speak? Check out the latest blog for details on how to enter for a chance to win!

Latest Blog: How to Set Up Multiple Log-Ins for Your Account
Want to set up multiple sets of credentials so different people in your office/home can log in to your account? Check out today's blog for more information on what you need and how to do it...
Paul2
Student
(0)
Solved (Go to Solution)

Lost MozyHome Service after Windows 10 Pro update

After a Windows 10 update 22 Jan 17 I no longer have MozyHome listed as a Local Service, so Status gets stuck at 'connecting to backup service' and I can't backup. How do I re-register the Mozy backup service for Windows 10?  If I have to uninstall / re-install will MozyHome have to backup all files again (>24 hours continuous last time so I'd prefer to avoid this). Any ideas?

0
JaredG
Moderator
(580)

Re: Lost MozyHome Service after Windows 10 Pro update

@Paul2

 

That means that the Mozy service is not running and needs to be Started.  Open Windows Services and scroll down to the Mozyhome backup service and right click on the service and choose "start".  If it's disabled then double click on the Mozyhome backup service enable under "startup type", then start the Mozy service by right clicking on the Mozyhome backup service and clicking on "Start" in the menu.

 

If the Mozy service stops again then usually antivirus or anti-malware are interfering with Mozy and exclusions need to be added so that it doesn't block the Mozy service.

 

Let us know if you have any questions or comments.

 

Thank you,

Jared
Mozy Support
0
Paul2
Student
(0)

Re: Lost MozyHome Service after Windows 10 Pro update

Dear Jared,

Thanks for taking the time to respond.  Unfortunately, as per my post, the <<the Mozyhome backup service >> has gone missing and is no longer listed in the Windows Services - possibly removed by the update.  I need to re-register it as a service, so that it can be started.  How do I do this please, ideally without having to re-install and start all local backups all over again? Is there a 'regsvr32 xxxx' command I can use?

 

If it might help, here is an extract from the logs on 22 - 26 Jan, as the problem occurred within these dates:

22Jan2017 21:38:41 mozybackup.exe: VERBOSE 200 000000000993E100 mordor:http:client .\http\client.cpp:480 6-113 HTTP/1.1 200 OK
22Jan2017 21:38:42 mozybackup.exe: INFO 200 0000000009932FE0 mordor:socket .\socket.cpp:313 0000000001DCE160 close(2292)
22Jan2017 21:38:43 mozybackup.exe: Finished backup with code: 0x00000000 0 1 1
22Jan2017 21:38:44 mozybackup.exe: INFO 1772 00000000010FAF00 mordor:socket .\socket.cpp:442 0000000001DCEA20 connectEX(2016, **Removed**:443) local: <localIP>:57249
22Jan2017 21:38:44 mozybackup.exe: VERBOSE 1772 00000000010FAF00 mordor:http:client .\http\client.cpp:471 7-1 GET /client/log_transfer?arch=<removed for post>

22Jan2017 21:38:45 mozybackup.exe: VERBOSE 1772 00000000010FAF00 mordor:http:client .\http\client.cpp:480 7-1 HTTP/1.1 200 OK
22Jan2017 21:38:45 mozybackup.exe: INFO 1772 00000000010FAF00 mordor:socket .\socket.cpp:313 0000000001DCEA20 close(2016)
26Jan2017 21:53:21 mozystat.exe: Starting
26Jan2017 21:53:21 mozystat.exe: Error: Can't open registry key 'HKLM\Software\mozy\scheduling' (error 5: access is denied.)
26Jan2017 21:53:21 mozystat.exe: Error: Can't set value of 'HKLM\Software\mozy\scheduling\skipped_schedule' (error 5: access is denied.)

I got lots more of this pair of Access Denied errors as well - repeated in the logs

 

The Windows updates installed between 22 and 26 Jan were: Security Update (KB3213986), Update (KB3176937), Update (KB3211320), and various updates to Visual Studio 2007 Tools for Applications.

 

Look forward to next steps.  Possibly a reinstall?

0
remymozy
Moderator
(95)
Solution

Re: Lost MozyHome Service after Windows 10 Pro update

@Paul2

 

Reinstalling Mozy without uninstalling will act as an upgrade, which depending on the state of Mozy's core files on your machine after the Windows 10 upgrade, should preserve things like backup selections and the state of your Mozy backups. 

0
Paul2
Student
(0)

Re: Lost MozyHome Service after Windows 10 Pro update

Hi Jared,

The reinstallation did the trick. I used 2.32.4.532 and have managed to complete an incremental backup for the last few weeks to catch up. 

 

Mozystat still seems to be unhappy from the logs - still getting 'access denied every few seconds:

<<

12Feb2017 14:44:08 mozystat.exe: Error: Can't open registry key 'HKLM\Software\mozy\scheduling' (error 5: access is denied.)
12Feb2017 14:44:08 mozystat.exe: Error: Can't set value of 'HKLM\Software\mozy\scheduling\skipped_schedule' (error 5: access is denied.)
12Feb2017 14:44:14 mozystat.exe: Error: Can't open registry key 'HKLM\Software\mozy\scheduling' (error 5: access is denied.)
12Feb2017 14:44:14 mozystat.exe: Error: Can't set value of 'HKLM\Software\mozy\scheduling\skipped_schedule' (error 5: access is denied.)
12Feb2017 14:44:27 mozystat.exe: Error: Can't open registry key 'HKLM\Software\mozy\scheduling' (error 5: access is denied.)
12Feb2017 14:44:27 mozystat.exe: Error: Can't set value of 'HKLM\Software\mozy\scheduling\skipped_schedule' (error 5: access is denied.)

>>

 

However, as far as I can see the backup has worked and there is no longer anything obviously wrong. Should I be worried about the 'access denied' issue?  Any suggestions to prevent this filling the logs forever?

I'll do a complete restart next and let you know if the error goes away, before marking the original fault 'solved'.

0
Benjamin_C
Moderator
(155)

Re: Lost MozyHome Service after Windows 10 Pro update

To be honest, I'm betting Windows thinks those registry keys are used by a different program (the version of Mozy on the older version of Windows), and is thus denying. If it's working, that's great, but if it ever stops working, or if you want to resolve the issue, you'll probably have to do a full uninstall of Mozy, and start over from scratch. (New config, everything). 

Benjamin_C
~Mozy Support

PS: If a response has resolved your issue, please mark it as a solution to help the Mozy Community!
0
AngelinaS
Moderator
(222)

Re: Lost MozyHome Service after Windows 10 Pro update

@Paul2   Was the information provided in this thread helpful in answering your questions?


If this helped you, please like the response given and press Accept as Solution.


Thank you,


Angie
Moderator

0
Paul2
Student
(0)

Re: Lost MozyHome Service after Windows 10 Pro update

Yes, thanks for the help - solved as marked.

Just the 'access denied' issue with the logs, but I can live with that for the time being.

0
JaredG
Moderator
(580)

Re: Lost MozyHome Service after Windows 10 Pro update

@Paul2

 

"Access denied" in the Mozy logs means that there are Windows permissions that are needed or usually antivirus or antimalware programs blocking Mozy and exclusions need to be added to stop blocking Mozy.

 

Antivirus or antimalware programs should all have an exclusions setting and you can either add the Mozy installation folder under C:\program files\Mozy\ for Mozyhome customers or C:\program files\Mozypro\ for Mozypro customers as a folder exclusion or for file exclusions added the four Mozy EXE files in the same directory.

 

Some antivirus or antimalware programs will continue to block Mozy after adding exclusions until the computer is restarted.

 

If you sill see "access denied" after added exclusions for Mozy and rebooting your computer then you need to look into Windows folder permissions next.

 

Thank you,

Jared
Mozy Support
0
Paul2
Student
(0)

Re: Lost MozyHome Service after Windows 10 Pro update

Hi Jared,

Excluding the four Mozy .exe file from McAfee LiveSafe real-time scanning and reboot didn't make any difference - still 'access denied'.  Could you be more specific about the Windows folder permissions correction needed please? Is there an existing post that gives the details of what I need to do?

0