Click to close the image preview

Showing results for 
Search instead for 
Do you mean 
Most Liked Users
User Reps Count
12
1
Announcements
Latest from the Blog: Trending KB Articles This Week
Check out the articles that are popular this week, and some other information and articles that can help you find further resolution if you're experiencing these issues.

Looking for Support?
Create a new post with your question and our community members and moderators will be happy to help answer it for you!
Highlighted
Fryer
Moderator
(536)
Solved (Go to Solution)

Update Required 0

You should have received an email about upgrading to the latest Mozy backup software. Our ongoing goal is to provide you with the best, most secure backup experience possible.

Starting March 18, Mozy will no longer support any version of the Mozy software prior to 2.22.2 for Windows and 2.12.2 for Mac. This means you need to take action today to update your Mozy software to the latest versions for Windows or Mac—or you could risk losing data by not having your backups function properly. When the “MozyHome Update Available” pop-up appears, you must click “Update Now” in order to continue backing up. If you click “Remind Me Later,” backups will cease and cannot resume until you have installed the new Mozy backup software.

By upgrading today, you can take advantage of many benefits, including:

    70 percent more error-free backups than earlier versions
    Data uploads that are as much as 25 percent faster
    File backups that require 33 percent less bandwidth
    An improved user interface that’s more than just good looks

We urge you to update now to ensure that backups continue without disruption. The update will only take a few minutes of your time.

Go to MozyHome download page

For more information, see How to install updates manually.

-
Please remember to mark the solution post and give thumbs up to helpful posts.

Mozy Premium Support
Senior Engineer

Term and conditions
http://mozy.com/terms

Latest Download
https://mozy.com/download/
0 Reps
DumbS
Student
(0)

Re: Update Required 0

I have an older MAC with the Motorola Processor and the latest operating system for that processor.   Apparently MOZY no longer supports that MAC series of computers.  Why would I pay MOZY if they cannot backup my Computer files?  Trying to contact MOZY has been a very bad experience for me.  They seem to want to hide behind technology and are very good at it.

 

DLA

0 Reps
Techalder
Moderator
(247)

Re: Update Required 0

Try this first...

 

 

https://support.mozy.com/MySupport

 

 

Go into chat and create a case and let's see what can be done...

 

Tech  :-)

0 Reps
DumbS
Student
(0)

Re: Update Required 0

My old MAC Mini has a Motorola Processor (Not Intel) and sits on my desk with the latest update from MOZY which my Computer says is not compatible with my operating system.  I have updated my operating system as far as it will go via Apple and the system seems to be working fine except for all sorts of invites from the WWW to upgrade my browser(s) so my "surfing experience will be more pleasurable."   

 

      My question is:  Is my MAC still being backed up by MOZY via the old backup program to the current on-line MOZY interface?  And, should I need my backup, will it be there for me, and in usable form?

 

     Cheers,

 

      DumbS

 

 

 

 

 

0 Reps
dillon
Community Manager
(128)
Solution

Re: Update Required 0

@DumbS,

 

Please see my reply to you in forum post:

http://community.mozy.com/t5/Mozy-for-Mac/Why-is-it-so-difficult-to-contact-a-warm-body-at-MOZY/m-p/...

Thanks,

Dillon
Mozy Senior Support Technician
Sync | Linux | Restore SME
0 Reps