Click to close the image preview

Showing results for 
Search instead for 
Do you mean 
Announcements
Did you know we have a Linux client? Read our blog article for more details. There is also a contest!
TummySup...

Elite Level 2
(20)
Solved (Go to Solution)

'mozyutil history' missing argument

I'm trying to mine a bit more information out of the mozyutil command, basically getting a better idea of how close my initial large backups are to finishing and what constitutes a Success or a Failure state for a backup.

 

The man page for the mozyutil command includes, in the history section, the argument "--bytes" described as:

 

--bytes   Display file sizes in bytes.

 

Yet when I run "mozyutil history --bytes", the command usage is returned with no mention of that argument.  Did that option get missed in the command whether it be in the parsing of arguments or simply left out?

 

I think I'm running the most recent version:


# mozyutil state --engine
General Info
-------------
Manual Backup Mode
Client Agent: msync_linux
Client Ver: 1.2.0.5005
Product: Mozybackup
State: AUTHENTICATED
Network connected: yes

Safe MO: 0

Download Cache: /tmp/downloadcache

 

Thanks!

Mike Loseke

0
zachm
Admin Emeritus
(386)

Re: 'mozyutil history' missing argument

Thanks for reaching out. I'm going to get a subject matter expert to hop on and talk to you about this.

Zach M.
Community Manager
0
BretA
Moderator
(161)

Re: 'mozyutil history' missing argument

@TummySupport2

 

Thank you for bringing this to our attention. I believe the command itself has changed and the man doc is not caught up. It's been a while, but I personally reviewed the man page before release and everything was accurate at the time. The '--bytes' option is supposed to make data sizes be displayed as a number of byes rather than in human-readable format (e.g. 4819 rather than 4.71KB).

The --bytes option serves the same purpose in other commands, and it appears to still be working in all of them except history. It seems history may have been changed to display in bytes by default, so the need for the --bytes argument was eliminated. A colleague has reached out to the client engineering team and our documentation team to determine exactly what's going on, and he will post what he finds out here.

 

To answer your question, a backup should only finish with 'Success' if every single file was successfully uploaded, or verified to already be on the servers. If even one file in the backup fails for some reason, the backup should return an appropriate error code. To view more specific details about the progress of a certain backup, use 'mozyutil history' to get the session ID of the backup you want to inspect, then use 'mozyutil history --details --id XX'. The output should indicate exactly which files were backed up and which were not. Alternatively, if the backup is currently running, you can use 'mozyutil queue' to see how close the backup is to finishing.

 

-BretA

0
dillon
Community Manager
(145)
Solution

Re: 'mozyutil history' missing argument

Hi Mike (@TummySupport2),

 

Sorry for the delay in response!

 

Turns out this was an adjustment and plans are for human-readable format, where --byte will provide exact bytes.

 

Version (1.2.0) currently shows in bytes as this originally planned as an option to export to another reporting module. Our developers are investigating this and will be modified for unity throughout Mozy.  As for a time frame, this will probably occur in the next release (1.3.0) which is a few months out. 

Thanks,

Dillon
Mozy Senior Support Technician
Sync | Linux | Restore SME
0
TummySup...

Elite Level 2
(20)

Re: 'mozyutil history' missing argument

Cool, thanks for checking in to it!

 

Mike

0